
Quick Start QSC Intuit QuickBooks Integration

Quick Shopping Cart 
QuickBooks Integration 
Installing and Configuring QuickBooks 
This guide walks you through setting up the Intuit QuickBooks Merchant Service 
(QBMS) payment gateway (where available) and downloading, installing, and 
configuring the QuickBooks Web Connector to exchange data with Quick Shopping 
Cart. To fully integrate Quick Shopping Cart with QuickBooks, you need an Intuit 
QuickBooks Merchant Service account. If you use a different payment gateway, you 
can configure Quick Shopping Cart to share data with QuickBooks. However, only the 
Intuit QuickBooks Merchant Service gateway allows you to reconcile Quick Shopping 
Cart credit card payments within QuickBooks.

Software Requirements
The Quick Shopping Cart Integration is compatible with QuickBooks Pro or Premier, 
2005 and later or QuickBooks Simple Start 2006 and later.

To update QuickBooks to a newer release, select Update QuickBooks from the 
QuickBooks File menu. Restart your computer after the update is installed. 

About QuickBooks Integration
The overall process for Quick Shopping Cart / QuickBooks integration is as follows:

1. Merchant who owns QuickBooks and Quick Shopping Cart (Deluxe or 
Premium) downloads, installs, and configures the Web Connector.

2. (Optionally) Merchant with a QBMS merchant account configures Quick 
Shopping Cart to accept credit cards via QBMS.

3. Shopper makes purchase on Quick Shopping Cart storefront.

4. Merchant processes payment in Quick Shopping Cart, ships order.

• order status = Shipped

5. Order is transferred to QuickBooks.

• Manually, via Update Selected in Web Connector

• Automatically, via schedule set in Web Connector

6. QuickBooks Sales Receipts shows the QSC order.

7. (Optionally) If merchant uses QBMS, merchant reconciles credit card orders 
in QuickBooks.
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Setting Up Intuit QuickBooks Merchant Service
To accept credit cards, you must have a secure certificate associated with your 
domain. After you purchase an SSL certificate and receive a confirmation email, 
return to the Payment Manager page to apply for a Intuit QuickBooks Merchant 
Service account (if available). 

If there is not a link to Intuit QuickBooks Merchant Service, you can use a different 
payment gateway. Otherwise, after you have obtained your Intuit QuickBooks 
Merchant Service account, return to the Payment Manager page to enable the 
account.

To Enable your Intuit QuickBooks Merchant Service Account

1. Log in to your Account Manager.

2. In the My Products section, click Quick Shopping Cart.

3. On the Quick Shopping Cart page, click Open next to the Quick Shopping Cart 
account you want to use.

4. Using the Advanced Builder, from the Processing menu, select Payments from 
the menu bar. 

5. Under Intuit QuickBooks Merchant Service, click Enable.

6. In the Intuit QuickBooks Merchant Service Configuration screen, under Account 
Management, click Go to Intuit QuickBooks Merchant Service. The Intuit 
QuickBooks Merchant Service login screen launches.

7. Log in using the Email and Password for your Intuit QuickBooks Merchant Service 
account.

8. In the Intuit QuickBooks Merchant Service Connection List screen, click Create 
New Connection.

9. On the Intuit QuickBooks Merchant Service Connection Setup screen, verify that 
Intuit QuickBooks Merchant Service is creating a ticket for Quick Shopping Cart, 
and then click Continue.

10.On the Intuit QuickBooks Merchant Service Connection Name screen, create a 
connection name and then click Continue. The Intuit QuickBooks Merchant 
Service Connection Setup Complete screen displays.

11. Click View Connection List. The Intuit QuickBooks Merchant Service 
Connection List screen displays. 

12. Select the Connection Name you created and then click Use this Connection. 
The Intuit QuickBooks Merchant Service Connection Setup Complete screen 
displays.

13. Click Close to close the browser window.

To Configure your Intuit QuickBooks Merchant Service Account 
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1. In the Quick Shopping Cart Intuit QuickBooks Merchant Service Configuration 
screen, under Account Management, click Verify to check that your Intuit 
QuickBooks Merchant Service (QMS) Connection is active. 

2. Select the payment card types that your store will accept.

3. If you sell downloadable products, select when the download will be available.

• Pre-Authorization - after the customer’s card has been pre-authorized, 
but before you have received payment.

• Authorization - after you have received payment.

3. Select how you would like your store to handle Address Verification System (AVS) 
and Card Verification Code (CVC) failures. The AVS compares the customer's 
provided billing address to the address on file with the card issuer. The CVS Code 
is used to validate card information.

• In Process - the customer is challenged to supply the correct address 
during checkout. If they fail to do so, the order is not completed and 
remains In Process.

• Potential Fraud - the order is placed normally and the customer is 
unaware that there is a failure. The order displays as “Potentially 
Fraudulent” in your Orders list until you fulfill or cancel the order.

4. Click Save. On the Enable Payment Options screen, QMS displays as Enabled.

5. Select Publish from the menu bar. You must publish for your changes to take 
effect on the storefront.

Set Up the QuickBooks Web Connector
Download, install, and configure the QuickBooks Web Connector and the QuickBooks 
Web Connector Configuration file to exchange data with Quick Shopping Cart. 

To Download the QuickBooks Web Connector

1. Under the Orders menu, select QuickBooks Integration.

2. On the QuickBooks Integration screen, the status is Inactive. Click Next.

3. On the Enable QuickBooks screen, read the Disclaimer, scroll to the bottom of 
the text, select "Yes, I Do Agree", and then click Next.

4. On the QuickBooks Password screen, create and confirm the password that you 
will enter in the QuickBooks Web Connector configuration and click Next.

5. Launch your QuickBooks application. 

6. Return to the Quick Shopping Cart Web Connector Installation and Configuration 
screen, and click Download the QuickBooks Web Connector. Follow the 
prompts to download the QuickBooks Web Connector.

7. Open the Web Connector file to begin the Configuration file installation process.
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To Download the Quick Shopping Cart Web Services File 

1. Return to the Quick Shopping Cart Web Connector Installation and Configuration 
screen and click Download the Quick Shopping Cart Web Services file. The 
file download dialog displays. 

2. Click Save.

3. Open the file. The Authorize New Web Service dialog displays.

You may be asked if you want to create a master key. If you select yes, 
you need to provide the master key every time you launch the 
QuickBooks Web Connector. 

4. Click OK to grant the Quick Shopping Cart Web Service access to your 
QuickBooks. The QuickBooks Web Connector dialog displays.

5. Select an option to grant the Quick Shopping Cart Web Service access to your 
QuickBooks company file.

• “Yes, prompt each time” - prompts you when the data exchange begins.

• “Yes, whenever this QuickBooks company file is open” - the data 
exchange takes place only when the QuickBooks company file is open.

• “Yes, always allow access even if QuickBooks is not running” - 
the data exchange takes place even if QuickBooks is closed.

6. Click Continue. The Access Confirmation dialog displays.

7. Click Done.

On the QuickBooks Web Connector screen, the Quick Shopping Cart Web Service 
displays in the Application list.

To Install the QuickBooks Web Connector and Configuration File 

1. In the QuickBooks Web Connector window, select Quick Shopping Cart Web 
Service from the Application List.

2. In the Password column, enter the QuickBooks Password you created 
previously in Quick Shopping Cart.

3. On the corresponding screen, verify that you want to save the password.

4. Click Update Selected. Wait for the data exchange to finish before you perform 
the next step.

5. Return to the Quick Shopping Cart QuickBooks Integration screen. On the Web 
Connector Installation and Configuration screen, click Next.

On the QuickBooks Integration screen, the status displays that the QuickBooks 
Web Connector has been successfully installed.
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To Configure QuickBooks Web Connector

1.  Click Edit QuickBooks Configuration Settings.

2. On the QuickBooks Integration Setup screen, configure the QuickBooks items that 
you want to use to store Quick Shopping Cart (QSC) data. Each QSC receipt will be 
associated with a single “generic” QSC item or account. 

Data for each QSC invoice is mapped to a single QuickBooks 
customer, item, item account, shipping charge (if you track it), 
sales tax (if you track it), and discount item (if you use Coupons). 
For example, in the QuickBooks Customer Center, all invoices 
from QSC are listed under a single: “Quick Shopping Cart 
Customer.” When you open an individual Sales Receipt, your 
customer’s name and address display in the Sold To section.

• Customer and Item – use the default provided or edit it if necessary. The 
customer (or item) is created in QuickBooks.

• Item Account – select the QuickBooks item account ― that you 
previously created in QuickBooks― under which you would like to show 
your Quick Shopping Cart sales receipts.

• Shipping Charge – use the default selection unless you want to use a 
shipping charge item that you already set up in QuickBooks.

• Sales Tax – use the default selection unless you want to use a sales tax 
item that you already set up in QuickBooks. 

• Credit Cards – use the default selections for the credit card payment 
method associated with each credit card that you accept unless you want to 
use different payment method items that you set up in QuickBooks.

• Quick Shopping Cart Receipt Import – select the starting date from 
which Quick Shopping Cart receipts will be imported to QuickBooks. Note 
that only those receipts for orders that have shipped are imported.

• Unattended Operation – indicate if the Quick Shopping Cart Web 
Service can access QuickBooks when QuickBooks is not open.

• Coupon Discount items – indicate whether you use discount coupons.

To fully enable unattended operations, open the QuickBooks Web 
Connector and enable Auto-Run for the Quick Shopping Cart 
Web Service. 

You may need to clear the Company File Location if you move 
your QuickBooks company file on your computer or start using a 
new one. If you do so, go into the QSC QuickBooks Integration 
Configuration page, clear the company file, and save the 
configuration. Next, open QuickBooks with the current company 
file, and then open the QuickBooks Web Connector. Click Update 
Selected to begin the update process from QSC to QuickBooks. 
After that, you will be able to run the Web Connector with 
QuickBooks closed.
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3. Click Save.

4. On the QuickBooks Integration screen, your configuration settings changes are 
acknowledged. You are directed to use the QuickBooks Web Connector to update 
the Quick Shopping Cart Web Service.

5. Return to the QuickBooks Web Connector.

6. Select Quick Shopping Cart Web Service.

7. Click Update Selected to run the data exchange. 

8. When the data exchange completes, you can select to Hide the QuickBooks Web 
Connector.

9. Return to the Quick Shopping Cart QuickBooks Integration screen, and then 
click Refresh. The QuickBooks configuration status displays as current. 

Congratulations, you have completed your QuickBooks Integration Setup.

Transferring Quick Shopping Cart Sales Receipts to 
QuickBooks 
Quick Shopping Cart orders are transferred to QuickBooks if:

• The order’s creation date is on or after the “Import Receipts” date set in the 
Quick Shopping Cart QuickBooks Configuration screen.

• The order status is Shipped.

To Manually Transfer Sales Receipts into QuickBooks

1. Open QuickBooks.

2. Launch the QuickBooks Web Connector.

• Under the File menu, select Update Web Services.

3. Select Quick Shopping Cart Web Service. 

4. Click Update Selected.

To Automatically Transfer QSC Sales Receipts into QuickBooks

1. Configure QuickBooks to accept automatic logins from the Quick Shopping 
Cart Web Connector:

• From the main menu, select Edit > Preferences.

• Select the Company Preferences tab.

• Select Integrated Applications.

• Select Exchange Data with Web Services, and then click 
Properties. Ensure that the “Allow this application to login 
automatically” option is selected.
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• Select Quick Shopping Cart Web Service, and then click 
Properties. Ensure that the “Allow this application to login 
automatically” option is selected.

2. Launch the QuickBooks Web Connector.

• Under the File menu, select Update Web Services.

3. In the QuickBooks Web Connector, select Auto-Run for the Quick Shopping 
Cart Web Service. In the Every_Min field, enter the interval, in minutes, at 
which you want to data transfer to start automatically. We recommend an 
interval based on your current sales volume with a minimum of 60 minutes.
For example: 60 minutes (once an hour)

240 minutes (every 4 hours)
600 minutes (every 6 hours)
720 minutes (every 12 hours)
1440 minutes (once a day)

Viewing QSC Sales Receipts in QuickBooks
Quick Shopping Cart (QSC) invoices are transferred into QuickBooks as Sales Receipts 
(not Invoices). The integration is designed to work where order payments are 
processed in QSC and shipped. Only QSC orders with a status of Shipped are 
transferred to QuickBooks.

In QuickBooks 2005:
1. Under the Customers menu, select Customer: Job list.

2. Right-click on the Quick Shopping Cart customer. If you edited the QSC 
Customer name in the QuickBooks Setup screen, then the name you entered 
displays in QuickBooks.

3. Select Quick Report.

4. Quick Shopping Cart sales receipts display. (You may need to change the date 
range).

In QuickBooks 2006 and 2007:
1. Navigate to the Customer Center.

2. Select the Quick Shopping Cart customer. If you edited the QSC name in the 
QuickBooks Setup screen, then the name you entered displays in QuickBooks.

3. Quick Shopping Cart sales receipts display. (You may need to select “All 
Transactions” or “Sales Receipts” under Show, or change the date range).

After using the QuickBooks Integration feature, you may want to 
change the mappings between QSC order data and QuickBooks items 
and accounts. See the instructions below for the version of 
QuickBooks you are using. 
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Changing Your QuickBooks Pro or Premier Settings
After using the QuickBooks Integration feature, you may want to change the mappings 
between Quick Shopping Cart (QSC) order data and QuickBooks items and accounts.

To Change the Quick Shopping Cart Customer

1. In QSC, from the Orders menu, Select QuickBooks Integration.

2. Select the Edit Configuration task.

3. Edit the Customer field, and then click Save.

4. Open QuickBooks, and open the company file.

5. Launch the QuickBooks Web Connector (Under the File menu, select Up-
date Web Services).

6. Select the Quick Shopping Cart Web Service and click Update Selected. The 
new QSC Customer is created in the QuickBooks customer list.

To Change the Quick Shopping Cart Item

1. In QSC, from the Orders menu, Select QuickBooks Integration.

2. Select the Edit Configuration task.

3. Edit the Customer field, and then click Save.

4. Open QuickBooks, and open the company file.

5. Launch the QuickBooks Web Connector (Under the File menu, select Up-
date Web Services).

6. Select the QSC Web Service and click Update Selected. The new QSC Cus-
tomer is created in the QuickBooks customer list.

To Change the Quick Shopping Cart Item Account

1. Open QuickBooks, and open the company file.

2. In QuickBooks, go to the Items list.

3. Edit the item and change the Account. Click OK.

7. Launch the QuickBooks Web Connector (Under the File menu, select Up-
date Web Services).

4. Select the Quick Shopping Cart Web Service and click Update Selected. The 
Quick Shopping Cart Item Account reflects the change.

To Change the Quick Shopping Cart Shipping Charge

1. Open QuickBooks, and open the company file.

2. In QuickBooks, go to the Item list, and create the new Shipping Charge item.

• The type must be “Other Charge” or “Service”.

• You are required to select an account to associate with the Shipping 
Charge. You may need to create a new account.
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3. Launch the QuickBooks Web Connector (Under the File menu, select Up-
date Web Services).

4. Select the Quick Shopping Cart Web Service and click Update Selec-
ted.

5. In QSC, from the Orders menu, select QuickBooks Integration.

6. Select Edit Configuration task.

7. Select Use other Shipping Charge Item from the QuickBooks Item list.

8. Find the new shipping charge item in the Shipping Charge drop-down and se-
lect it. Click Save.

To Change the Quick Shopping Cart Sales Tax

1. Open QuickBooks, and open the company file.

2. In QuickBooks, go to the Item list, and create the new Sales Tax item.

• The type must be “Sales Tax Item.”

• You are required to select a Tax Agency to associate with the Sales 
Tax. You may need to create a new agency.

3. Launch the QuickBooks Web Connector (Under the File menu, select 
Update Web Services).

4. Select the Quick Shopping Cart Web Service and click Update 
Selected.

5. In QSC, from the Orders menu, select QuickBooks Integration.

6. Select Edit Configuration task.

7. Select Use other Sales Tax Item from the QuickBooks Item list.

8. Find the new shipping charge item in the Sales Tax drop-down and select it. 
Click Save.

To Change a Quick Shopping Cart Discount Item

1. Open QuickBooks, and open the company file.

2. In QuickBooks, go to the Item list, and create the new Discount item.

• The type must be “Discount.”

• You are required to select an Account to associate with the Discount 
item. You may need to create a new account.

3. Launch the QuickBooks Web Connector (Under the File menu, select 
Update Web Services).

4. Select the Quick Shopping Cart Web Service and click Update 
Selected.

5. In QSC, from the Orders menu, select QuickBooks Integration.

6. Select Edit Configuration task.
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7. Select Use other Coupon Discount Item from the QuickBooks Item list.

8. Find the new discount item in the appropriate Coupon drop-down and select 
it. Click Save.

To Change a Quick Shopping Cart Credit Card Payment Method

Typically, you only need to do this if you accept Diners Club cards, 
since QuickBooks does not have pre-configured payment methods for 
Diners Club like it does for other major credit cards.

1. Open QuickBooks, and open the company file. 

2. Under the Lists menu, select Customer & Vendor Profile Lists, then 
Payment Method list.

3. Add the new payment method.

4. Launch the QuickBooks Web Connector (Under the File menu, select 
Update Web Services).

5. Select the Quick Shopping Cart Web Service and click Update 
Selected.

6. In QSC, from the Orders menu, select QuickBooks Integration.

7. Select Edit Configuration task.

8. Find the payment method in the appropriate Payment Method drop-down 
and select it. Click Save.

Changing Your QuickBooks Simple Start Settings
After using the QuickBooks Integration feature, you may want to change the mappings 
between Quick Shopping Cart order data and QuickBooks items and accounts.

To Change the Quick Shopping Cart Customer

1. In QSC, from the Orders menu, Select QuickBooks Integration.

2. Select the Edit Configuration task.

3. Edit the Customer field and click Save.

4. Open QuickBooks, and open the company file.

5. Launch the QuickBooks Web Connector (Under the File menu, select 
Update Web Services).

6. Select the QSC Web Service and click Update Selected. The new QSC 
Customer will be created in the QuickBooks customer list.
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To Change the Quick Shopping Cart Item

1. Open QuickBooks, and open the company file.

2. From the Orders menu, select QuickBooks Configuration.

3. Select the Edit Configuration task.

4. Edit the Item field, and click Save.

5. Launch the QuickBooks Web Connector.

6. Select the QSC Web Service and click Update Selected. The new QSC Item 
will be created in the QuickBooks item list.

To Change the Quick Shopping Cart Item Account

1. Open QuickBooks, and open the company file.

2. In QuickBooks, go to the Account list, and create the new account.

3. Launch the QuickBooks Web Connector. Select the Quick Shopping Cart Web 
Service and click Update Selected.

4. From the Orders menu, select QuickBooks Configuration.

5. Select the new account in the Item Account selection field, and click Save.

6. Select the QSC Web Service and click Update Selected. The new QSC Item 
Account is associated with the QuickBooks item account.

To Change the Quick Shopping Cart Shipping Charge

1. Open QuickBooks, and open the company file.

2. In QuickBooks, go to the Item list, and create the new Shipping Charge item.

• The type must be “Other Charge” or “Service.”

• You are required to select an Account to associate with the Shipping 
Charge. You may need to create a new account.

3. Launch the QuickBooks Web Connector. Select the QSC Web Service and click 
Update Selected.

4. From the Orders menu, select QuickBooks Configuration.

5. Select the new shipping charge in the Shipping Charge menu, click Save.

6. Select the QSC Web Service and click Update Selected. The new QSC 
Shipping Charge will be associated with the QuickBooks shipping charge.

To Change the Quick Shopping Cart Sales Tax

1. Open QuickBooks, and open the company file.

2. From the file menu, select Preferences.

3. In the Sales Tax Options section, select Yes for “Do you charge sales tax when 
you make a sale?”
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4. From the Tax Name drop-down, select Add New.

5. Enter the name for your new Sales Tax.

6. Enter the tax rate.

7. Enter a description and the tax agency.

8. Click OK.

9. Go to the Item list, and select the new Sales Tax item.

10. Launch the QuickBooks Web Connector. 

11. Select the Quick Shopping Cart Web Service and click Update Selected.

12. From the Orders menu, select QuickBooks Configuration.

13. Select the new sales tax item in the Sales Tax drop-down, and click Save.

14. Select the QSC Web Service and click Update Selected. The new QSC Sales 
Tax item will be associated with the QuickBooks sales tax item.

In order for Quick Shopping Cart to send the correct sales tax 
amounts to QuickBooks, you need to set up a Placeholder Sales Tax 
that defaults to 0%. Once you set up the Placeholder Sales Tax in 
QuickBooks, you can select it to ensure accurate reporting. 

To Set the Quick Shopping Cart Placeholder Sales Tax

1. Open QuickBooks, and open the company file. 

2. In QuickBooks, from the File menu, select Preferences. 

3. In the Sales Tax Options section, select Yes for "Do you charge sales tax when 
you make a sale?" 

4. From the Tax Name drop-down, select Add New. 

5. Enter the name for your Placeholder Sales Tax. 

6. Enter 0% as the tax rate. You cannot change this placeholder sales tax. 

7. Enter a description and a tax agency. 

8. Click OK. 

9. Launch the QuickBooks Web Connector. 

10.  Select the Quick Shopping Cart Web Service, and click Update Selected. 
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11. From the Orders menu, select QuickBooks Configuration. 

12. Select the 0% placeholder sales tax item in the Placeholder Sales Tax drop-
down, and click Save. 

13. Select the QSC Web Service and click Update Selected. The new QSC 
Placeholder Sales Tax item is associated with the QuickBooks placeholder 
sales tax item. 

To Change a Quick Shopping Cart Discount Item

1. Open QuickBooks, and open the company file.

2. In QuickBooks, go to the Item list, and create the new Discount item.

• The type must be “Discount.”

• You are required to select an Account to associate with the Discount 
item. You may need to create a new account.

3. Launch the QuickBooks Web Connector. Select the Quick Shopping Cart Web 
Service and click Update Selected.

4. From the Orders menu, select QuickBooks Configuration.

5. Select Use Coupon Discount Items from the QuickBooks Item list.

6. Select the new discount item in the appropriate Coupon drop-down, and click 
Save.

7. Select the QSC Web Service and click Update Selected. The new QSC 
Coupon Discount Item is associated with the QuickBooks discount item.

To Change a Quick Shopping Cart Credit Card Payment Method

Typically, you will only need to do this if you accept Diners Club 
cards, since QuickBooks does not have pre-configured payment 
methods for Diners Club like it does for the other major credit cards.

1. Open QuickBooks, and open the company file. 

2. Under the Lists menu, select Customer & Vendor Profile Lists, then 
Payment Method list.

3. Add the new payment method.

4. Launch the QuickBooks Web Connector. 

5. Select the Quick Shopping Cart Web Service, and click Update Selected.

6. From the Orders menu, select QuickBooks Configuration.

7. Select the payment method in the appropriate Payment Method drop-down, 
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and click Save.

8. Select the QSC Web Service and click Update Selected. The new QSC 
Payment Method is associated with the QuickBooks payment method.
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Quick Shopping Cart / QuickBooks Data Conversion 
This table lists the field mappings between Quick Shopping Cart Orders to 
QuickBooks Sales Receipts.

Quick Shopping Cart Intuit QuickBooks 

QuickBooks Integration Setup Customer 
(default = Quick Shopping Cart Customer)

Customer Full Name

Order Create Date Transaction Date

Order Invoice ID Reference Number

Billing Full Name Billing Address:  Address 1

Billing Address 1 Billing Address:  Address 2

Billing Address 2 Billing Address:  Address 3

Billing City Billing Address:  City

Billing State Billing Address:  State

Billing Postal Code Billing Address:  Postal Code

Billing Country Code Billing Address:  Country 

Shipping Full Name Shipping Address:  Address 1

Shipping Address 1 Shipping Address:  Address 2

Shipping Address 2 Shipping Address:  Address 3

Shipping City Shipping Address:  City

Shipping State Shipping Address:  State

Shipping Postal Code Shipping Address:  Postal Code

Shipping Country Code Shipping Address:  Country

Ship Date Ship Date

Credit Card Number Credit Card Number

Credit Card Expiration Month Credit Card Expiration Month

Credit Card Expiration Year Credit Card Expiration Year

Name on Credit Card Name on Credit Card

Billing Address Credit Card Billing Address

Billing Postal Code Credit Card Postal Code
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Quick Shopping Cart Intuit QuickBooks 

QuickBooks Integration Setup Item 
(default = Quick Shopping Cart Item)

– or –

QuickBooks Integration Setup Shipping 
Charge selection

– or –

QuickBooks Integration Setup Sales Tax 
selection

Item Full Name

QSC Product Name and Product Options

– or –

“Shipping Charge”

– or –

“Sales Tax”

Item Description

Quantity Quantity

Product Price

– or –

Shipping Charge

– or –

Sales Tax

Amount

Product Price Memo
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